[Samba] DC controller and DNS

ve2cii at ve2cii.com ve2cii at ve2cii.com
Mon Aug 2 15:45:06 UTC 2021

     Here is where we go away from the pack!! And another reason why I went
down the road I did.
I am using Slackware-14.2. (This cannot be changed)

I have an error in my samba log file as follows:  (no module name 'dns')

   samba version 4.13.9 started.
   Copyright Andrew Tridgell and the Samba Team 1992-2020
[2021/08/02 11:30:40.446237,  0] 
   binary_smbd_main: samba: using 'prefork' process model
[2021/08/02 11:30:40.536541,  0] 
   daemon_ready: daemon 'samba' finished starting up and ready to serve 
[2021/08/02 11:30:40.877388,  0] 
   /usr/sbin/samba_dnsupdate: Traceback (most recent call last):
[2021/08/02 11:30:40.877472,  0] 
   /usr/sbin/samba_dnsupdate:   File "/usr/sbin/samba_dnsupdate", line 
56, in <module>
[2021/08/02 11:30:40.877599,  0] 
   /usr/sbin/samba_dnsupdate:     from samba.dnsresolver import DNSResolver
[2021/08/02 11:30:40.877683,  0] 
   /usr/sbin/samba_dnsupdate:   File 
"/usr/lib/python3.9/site-packages/samba/dnsresolver.py", line 20, in 
[2021/08/02 11:30:40.877827,  0] 
   /usr/sbin/samba_dnsupdate:     import dns.resolver
[2021/08/02 11:30:40.877878,  0] 
   /usr/sbin/samba_dnsupdate: ModuleNotFoundError: No module named 'dns'
[2021/08/02 11:30:40.899410,  0] 
   dnsupdate_nameupdate_done: Failed DNS update with exit code 1


I have: (installed)

root at dns2:/var/adm/samba# python3 --version
Python 3.9.5
root at dns2:/var/adm/samba#

Plus: (installed)


    I tried downloading and compiling the latest dnspython-2.2.0 and I 
get the same
error. Bug perhaps??  Test machines have the same error and are working 

     As far as upgrading samba, I can do that pretty easily once I get 
this one working
properly.  I can go up to samba-4-13.9. 4-14.x won't compile on my 

On 8/2/21 11:31, Rowland Penny via samba wrote:
> On Mon, 2021-08-02 at 11:17 -0400, ve2cii--- via samba wrote:
>>      Ok I am right now recompiling samba with the dnsupdate turned on.
>> I am going to use samba-4.12.15 as that is what is running on my test
>> machines.
> What OS are you using ? You can get the latest Debian and Ubuntu
> packages here: https://apt.van-belle.nl/
> Latest version is always best, especially as 4.15.0 is scheduled for
> early next month, at which time 4.12.x will be EOL as far as Samba is
> concerned.
>>       I am going to read and try what you have said and let you know.
>>   From what you are saying I think I got it. There are 2 kinds of
>> files.
>> One is the standard zone files
>> what is known as a flat file (the standard bind9
>> zone file),
>> The other is the the ones that samba creates and uses which are in
>> the bind-dns directory.
>>     So basically I need to turn off the internal Samba dns server and
>> to do that I just add
>> server services = -dns
>>      And then do the configuration for the BIND9_DLZ Module.
>> Can you let me know if I am on the right track?
> Exactly, you just need the right settings in the bind9 named.conf
> files.
> Rowland

More information about the samba mailing list