[Samba] cifsacl not working - RESOLVED

Ken Bass kbass at kenbass.com
Sat Sep 26 15:48:27 UTC 2020

On 9/24/20 8:53 AM, Aurélien Aptel wrote:
> Ken Bass via samba <samba at lists.samba.org> writes:
>> I installed a new Ubuntu 20.4 LTS system (smbd 4.11.6) . Initially I
>> tried using the SSSD and 'realm' to join the domain. Everything worked
>> similar to my Centos 7 install and I thought I was finished.
>> The one thing not working is  cifs shares showing the proper id mapping.
>> Based on some online posts, including from Rowland, I got rid of SSSD
>> and configured samba/winbind only. Lots of posts saying 'winbind is not
>> sssd'. Still doesn't work.
> Do you have /etc/request-keys.conf setup to call cifs.idmap?
> Cheers,

Even though I have a /etc/request-key.d directory with a cifs.idmap.conf 
, I do not have a /etc/request-keys.conf file.
 From this clue as well as Rowlands recollection, installing the 
keyutils package fixed this. For whatever reason keyutils was not installed.
After installing keyutils, the system log started showing 'cifs.idmap' 
log entries and how mount.cifs is working.

So the cifs-utils package installs

However the package only has a 'suggestion' of the keyutils package. 
Without installing keyutils which creates the
/etc/request-key.conf file AND installed the /sbin/request-key binary, 
the 'cifsacl' option doesn't work / perform the winbind mapping as it 

Thanks Aurélien and Rowland for your help.

More information about the samba mailing list