[Samba] [SOLVED] Re: Trying to add workstation to smb domain and get access denied

L A Walsh samba at tlinx.org
Thu Sep 10 19:34:38 UTC 2020

On 2020/09/09 00:41, L.P.H. van Belle via samba wrote:
> [check C:\Windows\system32 ownership and ACL security settings
>  and verify Full access by Administrators group, from.. 
> https://nerdynerdnerdz.com/4192/solved-windows-domain-join-operation-was-not-successful-access-denied/ 
> ) ]
This was working correctly not too many days ago, but was very mangled
after the install of KB4508772 (attempt to fix a long-standing bug in my
Windows Event log not starting (since pre-Win8 days), giving the
error message:

  "Error 4201: The instance name passed was not recognized as valid
  by a WMI data provider."

that was accompanied by WMI failing with the message:

  "Server execution failed"

in response to most requests.  MS was never able to resolve the problem
(it persisted through SFC checks and in-place 'upgrade's using original
product disk to reset binaries + system state).  Their final answer, to
close out the original questions (a few others reported the problem
as well) years after it was first reported, was to upgrade to Win10,
where they assumed it was fixed or would not be duplicable (even though
they had no idea what caused the original problem).

Anyway, it was immediately after installing that patch (which
required a manual reboot, as well as a auto-reboot after applying
more changes) that my  system became unjoined from the domain
and had problems being re-added.

So thanks much for the advice to recheck OS-folder permissions.  It
wouldn't have occurred to me that a patch like that would have wiped
existing permissions forcing them to be re-applied.

Thanks very much for all the suggestions & input!


More information about the samba mailing list