[Samba] Trying to add workstation to smb domain and get access denied

L.P.H. van Belle belle at bazuin.nl
Wed Sep 9 07:41:56 UTC 2020

Im wondering why the message is : 
> This could be because an existing computer account having name 'ANY'

Your called Linda not Any ;- 

Its a case like this : 

I suspect you didnt sysprep your pc's and/or having multiple pc's with the same hostname. 

You can try/verify this if its not a "local" problem in the pc. 
1. Log onto the computer as a user as a local admin or a user with administrative priviledges
2. Open My Computer or Windows Explorer and Navigate to the following directory C:\Windows\System32
3. Locate then right-click the config folder select –> Properties ( the config properties page is displayed)
4. Select the Security tab
5. Click the continue button if it is present, otherwise locate the Administrators group or the user with Admin privileges ..
6. Select the Administrative group or User Account with Admin rights.
7. Under Permissions for Administrators click the Full control check box
8. Click Apply — if a windows security prompt appears, click Yes
9. If several Error Applying Security Access is denied windows appear click continue on all window pop-ups
10. Click OK on the Permissions for Config page — the page will close
11. Click OK on the config Properties page — the page will close
(source https://nerdynerdnerdz.com/4192/solved-windows-domain-join-operation-was-not-successful-access-denied/ ) 

The othere one is, remove (all same name) pc's  from the AD-domain. 
Rename/sysprep them and rejoin. 

After thats done, and its still nog working, then maybe its time to look at samba also. 



> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces at lists.samba.org] Namens L A 
> Walsh via samba
> Verzonden: woensdag 9 september 2020 4:20
> Aan: samba at lists.samba.org
> Onderwerp: [Samba] Trying to add workstation to smb domain 
> and get access denied
> Rebooted my system for a windows update.  When it came back up,
> It said the trust between my workstation and DC was broken.
> (Running Windows 7x64 SP1).  Very odd, haven't seen that for a while.
> I thought it would be easy: unjoin/rejoin.  But upon trying to rejoin,
> I get:
>   The join operation was not successful.  This could be 
> because an existing
>   computer account having name 'ANY' was previous created using a
>   different set of credential.  Use a different computer name, or
>   contact your administrator to remove any stale conflicting account
>   The error was Access is denied.
> I also tried it from the smb DC using 'net dom join...', but 
> get the same
> error: access is denied.
> Have never seen this.  I've tried changing the name to a computer name
> never existing on my network, but got the same message with no matter
> what computer name I put in.
> Help?
> Linda
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list