[Samba] Trying to add workstation to smb domain and get access denied

Rowland penny rpenny at samba.org
Wed Sep 9 07:20:20 UTC 2020

On 09/09/2020 03:20, L A Walsh via samba wrote:
> Rebooted my system for a windows update.  When it came back up,
> It said the trust between my workstation and DC was broken.
> (Running Windows 7x64 SP1).  Very odd, haven't seen that for a while.
> I thought it would be easy: unjoin/rejoin.  But upon trying to rejoin,
> I get:
>    The join operation was not successful.  This could be because an existing
>    computer account having name 'ANY' was previous created using a
>    different set of credential.  Use a different computer name, or
>    contact your administrator to remove any stale conflicting account
>    The error was Access is denied.
> I also tried it from the smb DC using 'net dom join...', but get the same
> error: access is denied.
> Have never seen this.  I've tried changing the name to a computer name
> never existing on my network, but got the same message with no matter
> what computer name I put in.
> Help?
> Linda

One thing you didn't say is what the DC is, as this is the samba mailing 
list and you mention 'smb DC', I think we can safely assume it is a 
Samba DC, but what version of Samba is it ?

Can you also tell us what OS you are using and supply a copy of the DC's 


More information about the samba mailing list