[Samba] Odd problems making AD DC

Dan Egli dan at newideatest.site
Thu Oct 29 00:41:32 UTC 2020

I am experiencing a weird issue with samba when I am trying to configure
it as a Domain Controller. I'm using Gentoo Linux, and after finally
figuring that kdb5_util was looking for the krb5.conf file where Gentoo
didn't put it, I was able to initialize the realm with kdb5_util create.
But now when I try to start samba (the actual Samba process, not smb) it
pulls kerberos and kerberos dies, saying:
 Can not fetch master key (error: No such file or directory). - while
fetching master key K/M for realm <myrealm>

After looking on the internet I see people getting this error before
krb5_util create, but not after. I tried kdb5_util stash and it says
it's using an existing key in the stash file, but I still get this same
error. Help? Samba is 4.13.0 with mit-krb5 1.18.2


Dan Egli
On my Test server

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 495 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20201028/bad44e66/OpenPGP_signature.sig>

More information about the samba mailing list