[Samba] samba start issues after classic upgrade

Rowland penny rpenny at samba.org
Sun Oct 18 19:25:55 UTC 2020

On 18/10/2020 20:08, Sonic wrote:
> On Sun, Oct 18, 2020 at 2:10 PM Rowland penny via samba
> <samba at lists.samba.org> wrote:
>> Why compile it yourself ?
> No special reason, just preference, been doing it for years.
>> [Service]
>> Type=forking
> Yes, I had already tried that and it seemed to be working, but I
> wasn't sure if that was the proper fix. Thanks for the verification.
Not saying it is the correct fix (I would be the last to know, what with 
normally using Devuan), but it hit me yesterday using Louis's repo. I 
set up a DC and ran 'sudo systemctl start samba-ad-dc' and it just sat 
there doing nothing for a long time until it timed out. I examined the 
the unit file and changed 'notify' to 'forking', no different, so 
changed the start line and changed back to notify, no different, so 
changed to forking again and this time it worked.


More information about the samba mailing list