[Samba] Samba Sysvol and GPO Issues

Franco Suarez frann.suarez at gmail.com
Tue Oct 13 18:24:10 UTC 2020

Hi Samba Team!

It's me again I'm having some issues with gpo's and sysvol access.

I've installed samba 4.12.7. using idmap_ldb:use rfc2307

When I tried to create a gpo using the rsat tools I got a Permission Denied

Among other things, I have run:
samba-tool ntacl sysvolreset

Also I added to smb.conf
acl_xattr:ignore system acls = yes
in sysvol and netlogon sections.
I tried to add 777 permissions to sysvol directory  and used the github
script "samba-check-set-sysvol.sh"

but the problem persists.

I got this error
==> log.smbd <==
[2020/10/13 14:56:20.544071,  0]
  chdir_current_service: vfs_ChDir(/var/samba/locks/locks/sysvol) failed:
Permission denied. Current token: uid=3000020, gid=3000004, 12 groups:
3000020 3000004 3000005 3000021 3000008 100 3000014 3000015 3000003 3000000
3000009 3000016

Any Ideas?
Thanks in advance
Juan Franco

More information about the samba mailing list