[Samba] Spotlight configuration trouble

Perttu Aaltonen perttu.aaltonen at mac.com
Fri Oct 2 13:24:00 UTC 2020

I’m trying to setup Spotlight with Tracker (2.3 from Ubuntu repo) backend in Ubuntu 20.04 and Samba 4.12.7. I’ve followed the wiki closely but every time I try to search I get this in the logs:

[2020/10/02 10:43:42.078242,  0] ../../source3/rpc_server/mdssvc/mdssvc_tracker.c:403(mds_tracker_search_start)
  mds_tracker_search_start: no connection to Tracker
[2020/10/02 10:43:42.079897,  0] ../../source3/rpc_server/mdssvc/mdssvc.c:935(slrpc_open_query)
  slrpc_open_query: backend search_start failed

And also sometimes this:

(process:80045): Tracker-WARNING **: 10:43:42.086: Falling back to bus backend, the direct backend failed to initialize: Could not find database file:'/root/.cache/tracker/meta.db’.

I’ve tried running tracker services with systemd and also directly under the mdssvc user but smbd isn’t able to connect to Tracker. I must have a configuration error somewhere or the problem is with either Tracker or Samba.

I also tried with Debian 10, Samba 4.11.13 and Tracker 2.1 and I get this when opening the share:

[2020/10/02 16:15:27.269248,  1] ../../source3/rpc_server/mdssvc/mdssvc.c:739(tracker_con_cb)
  Could not connect to Tracker: Failed to load SPARQL backend: Cannot autolaunch D-Bus without X11 $DISPLAY

So this points more to a DBus problem. I even tried to run Tracker under the root account but no change. The last time I tried Tracker backend was about two years ago and I got it working then, not sure what’s the problem this time.

Any pointers?

More information about the samba mailing list