[Samba] Some fileservers don't work when half of the DCs are down

Emilian Mitocariu mitocariu.emilian at gmail.com
Thu Nov 26 12:11:42 UTC 2020


I recently built a new set of DCs, joined them to the domain and moved the
FSMO roles to one of the new DCs. These new DCs are spread over 3 offices:
3 DCs for 1 office and 2 DCs for each of the other 2 offices. Same amount
for the old DCs.

The problem I'm facing is that I've tried to shutdown the old DCs to test
everything is working just with the new DCs, before demoting the old ones
from the domain. But I've started to get complaints that some of the
fileservers(samba as well) are not working anymore so I had to start the
old DCs back up. I believe the reason for this might be that when I do
"host -t SRV _ldap._tcp.domain.local" or "samba-tool dns query <DC>
domain.local @ A -U username" the old DCs are first in the list and the new
ones being so far up the list they don't even get to be tried. Is there a
way to change this order through samba-tool or something else?

Or if my hunch is not correct, please let me know what I should do? Also,
let me know if additional info is needed.

More information about the samba mailing list