[Samba] can't delete recursive DNS entry

Mani Wieser test_drive_123 at outlook.com
Tue Nov 17 15:54:06 UTC 2020


I tried the same; with the same result: my domain looks ( according 
samba-tools) like a copy from my domain in my domain, but the RSAT DNS 
tool (win 7 version) is showing "intern" and there are no items to show. 
The Active directory Explorer from Sysinternals shows it as 
"DC=briesebaer.intern;DC...." but no dnsProperty or dnsRecord...........

It is impossible to delete with samba-tools .....with adding a 
"test.test" domain I got an A-Record, which was deletable partly with 
samba-tool, but a test (as domain) was still there and not deletable (no 
data input available).

In the ADE it is easy to delete and than it disappears also from the 

@Rowland: Is this a bug?

BTW: don't rename an item in the RSAT DNS tool: it is disappearing due 
too wrongly written into the database: the field DNS_RANK_ZONE in the 
dnsRecord  is  Zero instead of 240 (decimal)...correcting with ADE 
brings it back again.


On 17.11.2020 15:55, Michael Thiemann wrote:
> Dear Mani
> The subdomain was created using the DNS RSAT Tool. Focus was on 
> briesebaer.intern and with a right cllick I choose to create a domain.
> There I gave the new domain the name briesebaer.intern. After this it 
> was as described before.
> This are the results of the DNS Lookups you requested.
> root at DRAGO:~# samba-tool dns query drago briesebaer.intern intern ALL 
> -U administrator
> Password for [BRIESEBAER\administrator]:
>   Name=, Records=0, Children=0
>   Name=briesebaer, Records=0, Children=1
> root at DRAGO:~# samba-tool dns query drago briesebaer.intern 
> briesebaer.intern ALL -U administrator
> Password for [BRIESEBAER\administrator]:
>   Name=, Records=7, Children=0
>     AAAA: fd00:0000:0000:0000:41e7:354c:d036:dbe4 (flags=600000f0, 
> serial=27217, ttl=900)
>     AAAA: fd00:0000:0000:0000:0011:32ff:fe28:a3b0 (flags=600000f0, 
> serial=27217, ttl=900)
>     SOA: serial=27218, refresh=900, retry=600, expire=86400, 
> minttl=3600, ns=tux.briesebaer.intern., 
> email=hostmaster.briesebaer.intern. (flags=600000f0, serial=27217, 
> ttl=3600)
>     NS: drago.briesebaer.intern. (flags=600000f0, serial=27217, ttl=900)
>     NS: tux.briesebaer.intern. (flags=600000f0, serial=27217, ttl=900)
>     A: (flags=600000f0, serial=27217, ttl=900)
>     A: (flags=600000f0, serial=27217, ttl=900)
>   Name=745E1C5866DF, Records=1, Children=0
>     A: (flags=f0, serial=26658, ttl=900)
>   Name=_sites, Records=0, Children=1
>   Name=_tcp, Records=0, Children=4
>   Name=_udp, Records=0, Children=2
>   Name=BAERCHEN, Records=1, Children=0
>     A: (flags=f0, serial=27216, ttl=1200)
>   Name=diego, Records=1, Children=0
>     A: (flags=f0, serial=10398, ttl=3600)
>   Name=DomainDnsZones, Records=0, Children=2
>   Name=DRAGO, Records=1, Children=0
>     A: (flags=f0, serial=18517, ttl=900)
>   Name=ForestDnsZones, Records=0, Children=2
>   Name=homematic-ccu2, Records=1, Children=0
>     A: (flags=f0, serial=27150, ttl=900)
>   Name=intern, Records=0, Children=1
>   Name=mani, Records=1, Children=0
>     A: (flags=f0, serial=15675, ttl=3600)
>   Name=PopCon, Records=1, Children=0
>     A: (flags=f0, serial=27217, ttl=1200)
>   Name=tux, Records=1, Children=0
>     A: (flags=f0, serial=18525, ttl=900)
>   Name=TX-8050, Records=1, Children=0
>     A: (flags=f0, serial=7047, ttl=3600)
>   Name=VSX-1021, Records=1, Children=0
>     A: (flags=f0, serial=7046, ttl=3600)
> root at DRAGO:~#
> Regards Michael
> Am 2020-11-17 15:20, Mani Wieser via samba <samba at lists.samba.org> 
> schrieb:
>     Dear Michael
>     How have you created the subdomain?
>     to look it up you have to exchange the @ with the name you want to see
>     samba-tool dns query drago briesebaer.intern intern ALL
>     and further down than:
>     samba-tool dns query drago briesebaer.intern briesebaer.intern ALL
>     Mani
>     On 17.11.2020 07:36, Michael Thiemann via samba wrote:
>     > Due to a mistake I created a subdomain with the name of the domain itself.
>     >
>     >   
>     >
>     > In my case the domain is briesebaer.intern and I created the subdomain
>     > briesebaer.intern.
>     >
>     > Using DNS RSAT Tool I see under briesebaer.intern the subdomain intern and
>     > then a recurrence of the whole domain.
>     >
>     > That means: under intern there is briesebaer and all of the dns query
>     > beneath.
>     >
>     >   
>     >
>     > The query shows the Name=intern with no Records and 1 child.
>     >
>     > The same happens in the reverse Zone automatic
>     ...

More information about the samba mailing list