[Samba] Extended attributes not working on mac

Martin Steiner / 3MF GmbH martin.steiner at 3mf-media.de
Fri May 29 21:22:15 UTC 2020

I worked with Netatalk for years and want to switch to Samba now. Currently i use Ubuntu 20.04. and Debian 9 before, i had no issues with netatalk at all.
As soon as i try to add a color tag (e.g. yellow) with Mac OS 10.15.5, the tag appears shortly but hides one second later. The file system is ZFS with no special options configured.

I tried the Ubuntu package but also the builds from source (4.12.1, 4.12.2, 4.12.3). Every attempt failed, i also tried every configuration combination which made sense to me. Finally i spent days with figuring out the problem but i have no glue at all.

The current config is basically the example from https://wiki.samba.org/index.php/Configure_Samba_to_Work_Better_with_Mac_OS_X:

min protocol = SMB2
vfs objects = catia fruit streams_xattr
fruit:metadata = stream
fruit:model = MacSamba
fruit:posix_rename = yes
fruit:veto_appledouble = no
fruit:wipe_intentionally_left_blank_rfork = yes
fruit:delete_empty_adfiles = yes

vfs objects = catia fruit streams_xattr
path = /home/buchhaltung
read only = No
valid users = martin


Maybe it is related to the xattr binary (also tried different versions) which tells me a unicode issue:
Traceback (most recent call last):
  File "/usr/local/bin/xattr", line 11, in <module>
    load_entry_point('xattr==0.9.7', 'console_scripts', 'xattr')()
  File "/usr/local/lib/python3.8/dist-packages/xattr-0.9.7-py3.8-linux-x86_64.egg/xattr/tool.py", line 196, in main
    attr_value = attr_value.decode('utf-8')
UnicodeDecodeError: 'utf-8' codec can't decode byte 0x9a in position 33: invalid start byte

Please help - thank you in advance!

More information about the samba mailing list