[Samba] Samba 4.11.8 on FreeBSD-12.1

James B. Byrne byrnejb at harte-lyne.ca
Fri May 29 19:57:13 UTC 2020

On Fri, May 29, 2020 14:57, James B. Byrne wrote:
> I have successfully provisioned a new domain but I see an issue that I would
> like to resolve before proceeding.  In smb4.conf I have these lines:
> 	bind interfaces only = No
> 	interfaces = lo eth0
> When I run 'smbclient -L localhost -U%' then I see this:
> WARNING: no network interfaces found
> 	Sharename       Type      Comment
> 	---------       ----      -------
> 	sysvol          Disk
> 	netlogon        Disk
> 	IPC$            IPC       IPC Service (Samba 4.11.8)
> SMB1 disabled -- no workgroup available

I worked around this by modifying smb4.conf to contain:

        bind interfaces only = Yes
	interfaces = localhost lo smb4-1 eth0
        server services = -nbt

The 'server services' entry is required because without it samba reports that
port 137 is already bound and then terminates.

However, the output still does not match what the wiki says to expect:

smbclient -L localhost -U%
Domain=[SAMDOM] OS=[Unix] Server=[Samba x.y.z]

I do not see the domain, OS or version displayed.


The favour of a direct copy of any reply to the list would be appreciated.

***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
 Do NOT open attachments nor follow links sent by e-Mail

James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3

More information about the samba mailing list