[Samba] Samba 4.11.8 on FreeBSD-12.1

Rowland penny rpenny at samba.org
Fri May 29 19:18:40 UTC 2020

On 29/05/2020 19:57, James B. Byrne via samba wrote:
> I have abandoned trying to get an existing AD-DC on a FreeBSD host using UFS to
> replicate successfully to a FreeBSD host on ZFS.  I am now in the process of
> provisioning a new domain on the ZFS host.
> The domain is created on a FreeBSD thick jail using IOcage as the jail manager;
> probably should be called the warden but I digress.
> I have successfully provisioned a new domain but I see an issue that I would
> like to resolve before proceeding.  In smb4.conf I have these lines:
> 	bind interfaces only = No
> 	interfaces = lo eth0
> When I run 'smbclient -L localhost -U%' then I see this:
> WARNING: no network interfaces found
> 	Sharename       Type      Comment
> 	---------       ----      -------
> 	sysvol          Disk
> 	netlogon        Disk
> 	IPC$            IPC       IPC Service (Samba 4.11.8)
> SMB1 disabled -- no workgroup available
> Before I proceed further I would like to know why are there no network
> interfaces found?  Is there some other configuration that I need to do to have
> samba find them?
Known problem fixed in 4.12.0, either comment out the lines or upgrade.

I do not think that a Samba DC will work correctly in a jail (but I am 
not an expert here). I did try (a few Samba versions ago) to run a Samba 
DC on Freebsd and failed, I tried with ZFS & UFS and the problem was the 
NFSv4ACL's, Samba just didn't like them. Things may have changed, but I 
suggest you discuss this with Timur (I think that is his name), he 
appears to be the expert on Samba and Freebsd.


More information about the samba mailing list