[Samba] Attribute or value exists during LDB_RENAME

Alex samba at abisoft.biz
Mon May 25 15:27:44 UTC 2020

Hello Rowland,

JFYI, I was able to fix it by restoring the object in AD on the Windows DC,
cleaning up Unix Attributes and then deleting it again.
Looks like the issue happened b/c I deleted the object with Unix Attributes (and
NIS group) set up.

> On 22/05/2020 13:18, Alex wrote:
>>> On 22/05/2020 12:59, Alex wrote
>>>> I apologies, I mistyped the value in grep. This one does find the record in
>>>> Samba:
>>>> # ldbsearch --cross-ncs --show-binary -H /usr/local/samba/private/sam.ldb -b 'CN=Users,DC=domain,DC=com' -s sub '(objectClass=group)' 2>&1 | grep videdom
>>>> dn: CN=videdom,CN=Users,DC=domain,DC=com
>>>> ...
>>> Try changing the search base to 'CN=Deleted Objects,DC=domain,DC=com'
>>> and see if the record exists there as well.
>> Yeah, I've already tried that:
>> # ldbsearch --cross-ncs --show-binary --show-deleted -H
>> /usr/local/samba/private/sam.ldb -b 'CN=Deleted Objects,DC=domain,DC=com' -s sub '(objectClass=group)' | wc -l
>> 496
>> # ldbsearch --cross-ncs --show-binary --show-deleted -H
>> /usr/local/samba/private/sam.ldb -b 'CN=Deleted Objects,DC=domain,DC=com' -s sub '(objectClass=group)' | grep vided | wc -l
>> 0
>> Also tried to restart samba - didn't help, errors still present in the log.
> That is weird, the deleted object doesn't seem to exist, but replication 
> thinks it does.

Best regards,

More information about the samba mailing list