[Samba] Attribute or value exists during LDB_RENAME

Alex samba at abisoft.biz
Fri May 22 12:18:58 UTC 2020

> On 22/05/2020 12:59, Alex wrote
>> I apologies, I mistyped the value in grep. This one does find the record in
>> Samba:
>> # ldbsearch --cross-ncs --show-binary -H /usr/local/samba/private/sam.ldb -b 'CN=Users,DC=domain,DC=com' -s sub '(objectClass=group)' 2>&1 | grep videdom
>> dn: CN=videdom,CN=Users,DC=domain,DC=com
>> ...

> Try changing the search base to 'CN=Deleted Objects,DC=domain,DC=com' 
> and see if the record exists there as well.

Yeah, I've already tried that:
# ldbsearch --cross-ncs --show-binary --show-deleted -H
/usr/local/samba/private/sam.ldb -b 'CN=Deleted Objects,DC=domain,DC=com' -s sub '(objectClass=group)' | wc -l

# ldbsearch --cross-ncs --show-binary --show-deleted -H
/usr/local/samba/private/sam.ldb -b 'CN=Deleted Objects,DC=domain,DC=com' -s sub '(objectClass=group)' | grep vided | wc -l

Also tried to restart samba - didn't help, errors still present in the log.

Best regards,

More information about the samba mailing list