[Samba] smbclient parallel_read returned NT_STATUS_IO_TIMEOUT

Gregory Sloop gregs at sloop.net
Mon Mar 30 02:43:15 UTC 2020

Trying to copy a large file from a Windows 10 box

Using smbclient - like so.
smbclient -U administrator%somepass //
mget *

mget starts, but then fails with the following details.
parallel_read returned NT_STATUS_IO_TIMEOUT
NT_STATUS_CONNECTION_DISCONNECTED opening remote file \abc.txt
smb: \> getting file \20191230-153202-def.7z of size 1607546951 as 20191230-153202-def.7z SMBecho failed (NT_STATUS_CONNECTION_DISCONNECTED). The connection is disconnected now

The problem version of smbclient is:
# smbclient --version
Version 4.9.15

Google finds very little and nothing that was helpful.

Tried limiting protocol to smb2, nada.
Saw some reports of: --socket-options='TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE' and with 'SO_RCVBUF=131072 SO_SNDBUF=131072", nada.
Probably a few other things I've tried, but can't recall now.

The file being copied is about 1.6G in size.
The failure occurs after pretty close to 100 seconds. [1m 40s]

I've tested coping the same files using the same credentials to a native Windows client - works fine.
Tested using a Ubuntu 16.04 smbclient same details, and it works fine. [Version 4.3.11-Ubuntu]

The host/cifs-server is Windows 10

It doesn't help that I know almost nothing about smbclient - so take it easy with the rack, hot tar, chains, and other torture implements, ok? 



More information about the samba mailing list