[Samba] DCs from 4.10.x to 4.11.x

Rowland penny rpenny at samba.org
Fri Mar 6 15:35:10 UTC 2020

On 06/03/2020 15:24, L.P.H. van Belle via samba wrote:
>> It might be, but it isn't the way I tried. I upgraded in the
>> way I have always done. First I got the reindexing for 5 hours and then when I..
> 5 hours? Ow wait on the Rpi?
No, on one of my DCS
>> decided to upgrade the other DC (which held all the FSMO roles),
> While the first still was running?
Yes, I have always done it like this and never had a problem (until now)
>> I couldn't transfer the FSMO roles to the upgraded DC and when
>> I tried to seize them to the DC instead, this failed.
> Wait the seize failed ? That should never happen. Thats why we have seize.
I sort of know this ;-)
>> I then tried to remove any tombstoned records on the upgraded DC, after 90 minutes,
>> I gave up and tried on the other, un-upgraded, DC and they were removed
>> almost instantly.
> Hm interesting, i have not seen that here.
No, neither have I :-(
> Something went seriously wrong during the upgrade, so I remove the
> upgraded DC, renamed and rejoined it, I now appear to have a fully
> working DC, but time will tell.
> And this was all raspbian? Or debian buster armhf?
No and No, this was on Devuan Beowulf (which you know as Buster)

I have absolutely no idea what went wrong, but I cannot recommend 
upgrading a Samba DC from 4.10.x to 4.11.x using just package upgrade. 
Stop the DC, remove it from the domain and then upgrade, finally rejoin 
the domain as a DC.


More information about the samba mailing list