[Samba] How to compile gnutls to samba-4.12.3

Sérgio Basto sergio at serjux.com
Thu Jun 18 02:29:33 UTC 2020

On Wed, 2020-06-17 at 22:03 -0400, Rommel Rodriguez Toirac via samba
> Hello all;
>  sorry almost the offtopic.
>  I want to upgrade to samba-4.12.3.tar.gz on CentOS 7 and has problem
> installing gnutls.
>  As said in wiki, to install samba-4.12.3 you need to install a
> version equal to or greater than 3.4.7 of gnutls. This (gnutls)
> depends on nettle and gmp. I am trying to install gnutls-3.6.14; I
> already have gmp (gmp-6.2.0) and nettle (nettle-3.6) installed
> (compiled from sources), but gnutls doesn't want to install, it tells
> me "Libnettle 3.4.1 was not found" when I run the ./configure
> Nettle is installed in /usr/local/include/nettle (all .h) and in
> /usr/local/lib64/libnettle.s0.8.0
> I created a symbolic link for /usr/lib64 from
> /usr/local/lib64/libnettle.s0.8.0 as libnettle.so and libnettle.so.8;
> I ran the gnutls ./configure again, but it keeps saying it can't find
> libnettle 3.4.1
> How can I install gnutls?
> Has anyone got CentOS 7 and samba-4.12.3 installed and fixed this
> situation that explaim me how to do that?

I made compat-gnutls34 and compat-nettle32 packages , because half of
Centos 7 depends system gnutls and you can't just upgrade it .
After install compat-gnutls34 and compat-nettle32 before run
./configure you just need run export PKG_CONFIG_PATH=/usr/lib64/compat-

Just a note you just need gnutls-3.4.7 if you will use MIT Kerberos
integration if you use Heimdal Kerberos I think gnutls of Centos 7still enough [3] . 




> --
> Rommel Rodriguez Toirac
> rommelrt at nauta.cu
> -- 
> Rommel Rodriguez Toirac
> rommelrt at nauta.cu
Sérgio M. B.

More information about the samba mailing list