[Samba] [EXTERNAL] Could not access a share as a guest

Neelakantan Kannappa (nkannapp) Neelakantan.Kannappa at quest.com
Tue Jun 9 08:42:01 UTC 2020

Appreciate your help.

Yes that is true. Those files are created by some other Application(which are shared through samba).

Ran wireshark, captured the packets and filtered for SMB2. Attached SMB2 filtered packets in a plain text format.

I don't know what is happening from the packet tracing.

SMB did create request, create response and immediately close request & close response.  Session logged off.

Even I tried "ea support = no" that also did not help.

Tried other alternative with below smb conf.

#   acl_xattr:ignore hashes = yes
#   acl_xattr:ignore system acls = yes
#   acl_xattr:default acl style = everyone

Things work properly when windows client & samba server(linux) nodes are joined to a domain.

Neelakantan K.

-----Original Message-----
From: Jeremy Allison <jra at samba.org> 
Sent: Tuesday, June 9, 2020 1:50 AM
To: Neelakantan Kannappa (nkannapp) <Neelakantan.Kannappa at quest.com>
Cc: Ashok Ramakrishnan <aramakrishnan at nasuni.com>; samba at lists.samba.org
Subject: Re: [Samba] [EXTERNAL] Could not access a share as a guest

CAUTION: This email originated from outside of the organization. Do not follow guidance, click links, or open attachments unless you recognize the sender and know the content is safe.

On Mon, Jun 08, 2020 at 06:31:59PM +0000, Neelakantan Kannappa (nkannapp) via samba wrote:
> Hi Ashok,
> That solved this issue and moved ahead of that IPC$ share access issue. Thanks for that.
> Now, I am seeing the below error.
> Please note I am new to samba world. Pardon me if I am asking for more.
> Meanwhile I too will check smb.conf online doc and my smb.conf for any conflicting configurations.
> [2020/06/08 12:23:08.982042,  5, pid=471, effective(0, 0), real(0, 0)] ../../source3/smbd/dosmode.c:449(get_ea_dos_attribute)
>   get_ea_dos_attribute: Cannot get attribute from EA on file 
> 1d972c9a-6afe-4c46-ba77-7fdf8c24af5a#b079d2d8-0000-0000-0000-000000000
> 000#3-snapshot.vhdx: Error = No data available
> [2020/06/08 12:23:08.982063, 10, pid=471, effective(0, 0), real(0, 0)] 
> ../../source3/smbd/open.c:3185(open_file_ntcreate)

That is not necessarily an error. The file may not have had the DOS attributes stored on it yet, if this is the first time it's being accessed by Samba (on read for example).
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: smb2-pcap.txt
URL: <http://lists.samba.org/pipermail/samba/attachments/20200609/cec5994c/smb2-pcap.txt>

More information about the samba mailing list