[Samba] samba-tool domain classicupgrade fails to import users or groups from NT domain

Sebastian Arcus s.arcus at open-t.co.uk
Tue Jun 2 12:55:11 UTC 2020

On 02/06/20 13:08, Rowland penny via samba wrote:
> On 02/06/2020 12:16, Sebastian Arcus via samba wrote:
>> Does anybody have any idea what might be happening here? I've just 
>> copied the configs and databases and Linux users to another machine 
>> with Samba 4.6.7 - and classicupgrade does the same thing - it doesn't 
>> import any users. I am guessing that maybe Samba doesn't recognise the 
>> users as belonging to the NT domain somehow?

Hi Rowland - thank you for the suggestions. I think I've managed to fix 
things - sort of - but I don't understand what is going on. I have 
posted the information you required below for reference purposes anyway 
- in case it helps.

I the course of trying all the permutations I could think of, I tried to 
run the classicupgrade with the gencache_notrans.tdb file missing. 
Amazingly, it imported all the users from the NT domain! The problem is 
that I have no idea what the gencache_notrans.tdb file contains and why 
was it preventing the users from being imported - without even 
generating any error?

> Can you post the smb.conf from the NT4-style PDC you are upgrading from ?

Posted below - I've reduced it to absolute minimum to see if it will 
work. Still no joy

> What version of Bind is installed ?

On the original server I have Bind 9.16.3, on the testing machine I have 
Bind 9.11.2

> Have you tried without '--dns-backend=BIND9_DLZ' ?

I have now - still no users imported I'm afraid


netbios name = SA-SERVER
workgroup = SINCLAIR
server string =

security = user
domain master = yes
local master = yes
preferred master = yes
domain logons = yes
os level = 255
wins support = no

passdb backend = tdbsam

More information about the samba mailing list