[Samba] samba-tool domain backup offline stalls

James B. Byrne byrnejb at harte-lyne.ca
Wed Jul 22 18:40:33 UTC 2020

On Wed, July 22, 2020 12:35, James B. Byrne wrote:
> FreeBSD-12.1p7 jail running Samba-4.10.15 on ZFS.
> When I run 'samba-tool domain backup offline targetdir=/tmp' I see this:
> running backup on dirs: /var/db/samba4/private /var/db/samba4 /usr/local/etc
> Starting transaction on /var/db/samba4/private/secrets

I tried the backup online option instead and received a timeout error:

ERROR(runtime): uncaught exception - (3221225653, '{Device Timeout} The
specified I/O operation on %hs was not completed before the time-out period
  File "/usr/local/lib/python3.7/site-packages/samba/netcmd/__init__.py", line
185, in _run
    return self.run(*args, **kwargs)
  File "/usr/local/lib/python3.7/site-packages/samba/netcmd/domain_backup.py",
line 249, in run
  File "/usr/local/lib/python3.7/site-packages/samba/join.py", line 1555, in
  File "/usr/local/lib/python3.7/site-packages/samba/join.py", line 1632, in
  File "/usr/local/lib/python3.7/site-packages/samba/join.py", line 100, in
    ctx.site = ctx.find_dc_site(ctx.server)
  File "/usr/local/lib/python3.7/site-packages/samba/join.py", line 361, in
    flags=nbt.NBT_SERVER_LDAP | nbt.NBT_SERVER_DS)

I infer that this is related to the ntpd service which listens at TCP137.  This
service is not running on this host because it is disabled in smb.conf.  The
reason that it is disabled is that samba_server does not start:

[2020/07/22 12:48:49.786881,  0] ../../source4/smbd/server.c:587(binary_smbd_main)
  samba version 4.10.15 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2019
[2020/07/22 12:48:50.079799,  0] ../../source4/smbd/server.c:773(binary_smbd_main)
  binary_smbd_main: samba: using 'standard' process model
[2020/07/22 12:48:50.103387,  0]
[2020/07/22 12:48:50.150866,  0] ../../lib/util/become_daemon.c:136(daemon_ready)
  daemon_ready: daemon 'samba' finished starting up and ready to serve connections
[2020/07/22 12:48:50.184811,  0]
  task_server_terminate: task_server_terminate: [nbtd failed to setup interfaces]
[2020/07/22 12:48:50.300712,  0] ../../source4/smbd/server.c:371(samba_terminate)
  samba_terminate: samba_terminate of samba 86503: nbtd failed to setup interface

Anyone know how to deal with this?

***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
   Unencrypted messages have no legal claim to privacy
 Do NOT open attachments nor follow links sent by e-Mail

James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3

More information about the samba mailing list