[Samba] Installing Samba 4 on Redhat 6.

Mark London mrl at psfc.mit.edu
Fri Jul 10 04:16:45 UTC 2020

I was able forcibly remove the samba 3 rpms from Redhat 6 without 
breaking KDE.  So far so good.

I've lost too many weeks of my life, debugging disk sharing issues.   
Bring back main frame computing, I say.

On 7/9/2020 1:43 AM, Mark London wrote:
> Hi - Samba 3 had been running for years on a Redhat 6 box that I can't 
> upgrade.    Suddenly it stopped allowing windows client to access it.  
> After trying many things,  I then tried a "net ads leave" and then 
> tried a "net ads join."   The join fails with this error message:
>          Failed to join domain: failed to lookup DC info for domain 
> 'PSFC.MIT.EDU' over rpc: Unexpected information received
> I can duplicate the problem on a clean install of Samba 3 on another 
> Redhat 6 computer.    I can't find anyone with a similar error message 
> on the web.   I can post the debug output from the join command, if 
> anyone thinks they can help debug the problem.
> But since Samba 3 is no longer supported, I thought it best to try and 
> install Samba 4.   The problem is that Yum complains that Samba 3 
> conflicts with it.  See below.   And when I try to erase samba 3, it 
> says it has to remove kdebase and kdm and related packages. Does 
> anyone know a work around?   Can I forcibly remove the old Samba 3 
> without removing the dependencies?  Thanks. - Mark
> ..... 

More information about the samba mailing list