[Samba] Installing Samba 4 on Redhat 6.

Rowland penny rpenny at samba.org
Thu Jul 9 08:00:51 UTC 2020

On 09/07/2020 06:43, Mark London via samba wrote:
> Hi - Samba 3 had been running for years on a Redhat 6 box that I can't 
> upgrade.    Suddenly it stopped allowing windows client to access it.  
> After trying many things,  I then tried a "net ads leave" and then 
> tried a "net ads join."   The join fails with this error message:
>          Failed to join domain: failed to lookup DC info for domain 
> 'PSFC.MIT.EDU' over rpc: Unexpected information received
> I can duplicate the problem on a clean install of Samba 3 on another 
> Redhat 6 computer.    I can't find anyone with a similar error message 
> on the web.   I can post the debug output from the join command, if 
> anyone thinks they can help debug the problem.
> But since Samba 3 is no longer supported, I thought it best to try and 
> install Samba 4.   The problem is that Yum complains that Samba 3 
> conflicts with it.  See below.   And when I try to erase samba 3, it 
> says it has to remove kdebase and kdm and related packages. Does 
> anyone know a work around?   Can I forcibly remove the old Samba 3 
> without removing the dependencies?  Thanks. - Mark
Never mind Samba 3 no longer being supported, by the end of the year, 
unless you pay for extended support, RHEL6 will no longer be supported 
(and if it is Centos, there is no extended support).

I think your problem may be caused by your Windows clients not using 
SMBv1 any more, if this is the case, you could turn it back on, but be 
aware that SMBv1 is very insecure.

You should take this as a wakeup call and upgrade to Samba AD.


More information about the samba mailing list