[Samba] Issues with FLOCK on NFS Share

Rowland penny rpenny at samba.org
Mon Jul 6 15:05:44 UTC 2020

On 06/07/2020 15:30, Georg.Biberger--- via samba wrote:
> Hello,
> When I run "cat /etc/passwd | grep 'qqeda11'", on my linux box, I get:
> qqeda11:x:79846:65600:Project Account for EDA:/home/qqeda11:/bin/bash
That makes 'qqeda11' a LOCAL Unix user
> When I run "wmic useraccount where (name='qqeda11' and domain='MUC') get name, sid" on my windows box, I get:
> Name     SID
> qqeda11  S-1-5-21-43206524-2104247658-1151357142-1581344
That makes 'qqeda11' an AD user.
> so the user is an AD user, but also an unix user. I think this is a legal construct.

Nope, cat /etc/passwd | grep 'rowland' produces no output for myself, 
but 'getent passwd rowland' produces:

rowland:*:10000:10000:Rowland Penny:/home/rowland:/bin/bash

You cannot have the same user in /etc/passwd and AD (and before someone 
jumps in and says you can, yes it is possible, but it isn't supported 
and leads to problems like this)

I would suggest you use my BOTCH (but do not use any other AD users or 
groups) or, better still, use the 'ad' backend and give your user the 
uidNumber '79846'. Either way, delete the user on the Unix machine.


> Is there another way to tell samba to use the correct mapping? What about modifying winbindd_idmap.tdb manually?
> Georg

More information about the samba mailing list