[Samba] Unable to create files containing ":" despite using vfs_catia

Trolli Schmittlauch t.schmittlauch+ml at orlives.de
Sun Jul 5 02:30:38 UTC 2020

Hi everyone,

for making the files on my NAS accessible to Windows users as well without restricting the file naming on my Linux machines, I need to map illegal characters to legal ones using vfs_catia.

But despite having the mapping enabled in my [global] section, I cannot create files or directories containing a colon from my Linux client.

I have these lines in the [global] section of my smb.conf:

vfs objects = catia
catia:mappings = 0x003a:0x2236,0x003f:0x0294,0x002a:0x2217,0x003c:0x276e,0x003e:0x276f,0x0022:0x02ba,0x007c:0x2223,0x005c:0x29f9

I've also tried various other catia_mappings from the man page or examples around the internet, all containing a mapping for ":", none of them worked.
I am using either smbnetfs or the KDE kio smb integration for accessing the Samba share and creating files. Does vfs_catia only work with mount.cifs or did I make a configuration mistake?
The way I understand what catia does is that I can still provide illegal characters from Linux/UNIX clients, whith illegal characters being mapped for windows clients. Is that assumption correct?

samba version used: 4.12.3+git.161.208cf9730ee-1.1

I appreciate any help on this issue, it's been bugging me for years now.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20200705/226112f9/signature.sig>

More information about the samba mailing list