[Samba] smbd fails to start after upgrade to version 4.11.6

Roy Eastwood spindles7 at gmail.com
Wed Jan 29 22:28:43 UTC 2020

> On 29 January 2020 21:38 Rowland penny via samba wrote:
> >
> > Louis' script failed to print out smb.conf (even though it exists at
> > /etc/samba/smb.conf) and user.map, so here they are:
> I think you found a slight bug in the script, I will look into trying to fix it.


> It confirms that nmbd, smbd and winbind are not starting, so do you have SSH setup on your Rpi ?

Yes.  windbindd starts, but as smbd had failed I had stopped it before running the scripts.   I don't run nmbd (I use wsdd instead).
> if so, can you open three ssh terminals to the Rpi and run 'sudo smbd -D' in one, 'sudo nmbd -D' in the second and 'sudo winbindd -D'
> in the third. If they all start, check if Samba is running on the Rpi, if one fails it may point in the direction of the error.
> If it does work, it may be a problem with systemd and I know little about systemd.
> Rowland

There was no output to the ssh terminal when I ran these three commands, but smbd.log shows:

[2020/01/29 21:56:02.994213,  1] ../../source3/profile/profile_dummy.c:30(set_profile_level) 
 INFO: Profiling support unavailable in this build.
[2020/01/29 21:56:03.036706,  0] ../../lib/util/become_daemon.c:136(daemon_ready)
  daemon_ready: daemon 'smbd' finished starting up and ready to serve connections
[2020/01/29 21:56:03.543683,  0] ../../source3/smbd/server.c:1241(open_sockets_smbd)
  open_sockets_smbd: No sockets available to bind to.
[2020/01/29 21:56:03.545039,  0] ../../source3/lib/util.c:824(smb_panic_s3)
  PANIC (pid 1647): open_sockets_smbd() failed
[2020/01/29 21:56:03.545743,  0] ../../lib/util/fault.c:265(log_stack_trace)
  BACKTRACE: 0 stack frames:
[2020/01/29 21:56:03.545970,  0] ../../source3/lib/dumpcore.c:315(dump_core)
  dumping core in /var/log/samba/cores/smbd

The output of ps shows these commands running but no ports are open:
root at pi4b:~# ps ax | grep -E 'smbd|winbindd|nmbd'
 1764 ?        S      0:00 smbd -D
 1765 ?        S      0:00 smbd -D
 1771 ?        Ss     0:00 winbindd -D
 1772 ?        S      0:00 winbindd: domain child [SAMDOM]
 1775 ?        Ss     0:00 nmbd -D
 1778 pts/0    S+     0:00 grep -E smbd|winbindd|nmbd

netstat -tanp
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0  *               LISTEN      559/vncserver-x11-c
tcp        0      0*               LISTEN      592/python3
tcp        0      0    *               LISTEN      567/sshd
tcp        0    272      ESTABLISHED 1465/sshd: root at pts
tcp        0      0      ESTABLISHED 1505/sshd: root at pts
tcp        0      0      ESTABLISHED 1528/sshd: root at pts

Tried turning debug up to 10 with smbd -d10 -D, but that produced so much output in the log I can't see the wood for the trees 😉



More information about the samba mailing list