[Samba] Problems joining DC (tried 4.11.4 and 4.10.13)

Jonathan Hunter jmhunter1 at gmail.com
Tue Jan 28 13:58:10 UTC 2020

On Tue, 28 Jan 2020 at 10:57, Rowland penny via samba
<samba at lists.samba.org> wrote:
> > I'm not sure why samba-tool isn't prompting for the password when I
> > join the domain, I've never had that before.
> Hmm, you aren't supplying a password and you do not seem to be prompted
> for one, so either a random password or no password is being used, this
> leads to the LDAP error.
> Can you try adding '--password=<the password for adminuser>' to the join
> command

Thank you - that worked and has allowed the machine to join the domain :)

I did read the --help output for 'samba-tool domain join' but it was
late at night and I must have missed the part about password (or
didn't think to try it). Sometimes the simplest things are easy to
miss, I guess - thanks for the suggestion. I'm still not sure where
samba-tool was getting its password from but at least it has worked

Now that newdc is running, I am still getting the replication errors
from other DCs even now I am back on 4.10.x :( Clearly it's not an
issue with 4.11.x, then, so I will post a separate email on that.

> >> Can I also suggest you use Louis's repo: http://apt.van-belle.nl/
> I use Louis's packages on my Rpi4 and they work well.

Ahh that's good to hear, thank you! I am trying Rpi4 for the first
time as it happens; I have migrated from rpi2 to rpi3 over the years
and am about to move to rpi4 :)

"If we knew what it was we were doing, it would not be called
research, would it?"
      - Albert Einstein

More information about the samba mailing list