[Samba] Samba4 syncpassword fails

Rowland penny rpenny at samba.org
Thu Aug 13 15:30:52 UTC 2020

On 13/08/2020 15:47, Julien TEHERY via samba wrote:
> Hello,
> We are facing an issue with samba syncpassword which doesn't work anymore.
> We use it to synchronize samba4 password into a remote ldap used by applications.
> It has been working flawlessly for more than 2 years.
> Our architecture:
> 2 main DC on the main site and about 10 remote DC (with site topology).
> We  synchronize the password with a daemonized python script used on every DC.
> For this an ldb cache is generated
> One day, after promoting a new remote DC, the sync began to fail on every DC.
> We tried to recover the first main DC from a backup,
Never restore a DC from a backup, unless it is the only DC and then you 
restore the domain not the actual DC as such
> the sync worked, until we added a new DC and it failed again with the following error:
Where did you get the password sync script from ? Are you aware that 
samba-tool now has the facility to do this ?

Have a look here:



More information about the samba mailing list