[Samba] Domain admin has no access to C:\Windows\system32\rundll32.exe

Rowland penny rpenny at samba.org
Thu Aug 6 19:03:12 UTC 2020

On 06/08/2020 19:49, James B. Byrne wrote:
> On Thu, August 6, 2020 14:42, James B. Byrne wrote:
>> On Thu Aug 6 17:14:11 UTC 2020 Rowland penny rpenny at samba.org wrote:
>>> No, either case will work on Linux.
>>> How did you log into the laptop ?
>>> did you just log in as 'Administrator' or as 'BROCKLEY\Administrator' ?
>> Originally I logged in as BROCKLEY\administrator.  I also logged on as
>> BROCKLEY\Administrator and that was converted to BROCKLEY\administrator by Win
>> 10 during the logon process.
>> I also added BROCKLEY\administrator to the local Admins group without solving
>> the problem.
> An answer is found here
> https://social.technet.microsoft.com/Forums/en-US/fb3bad72-82fb-4d74-9777-ddff71692707/domain-administrator-no-permissions-local-admin-has-permissions?forum=win10itprogeneral
> For your question, please run gpedit.msc to open Group Policy Editor, then
> switch to Computer Configuration---> Windows Settings---> Security Settings
> ---> Local Policies---> Security Options, then enable "User Account Control:
> Admin Approval Mode for the Built-in Administrator account", after all restart
> Windows to take effect. Figure as below:
> I have not tried it yet. I will let you know how it goes.
I was just going to suggest that you may have to use a GPO, because I 
have just tested what you tried and got the same result, so I think it 
is a Windows problem rather than an AD problem.


More information about the samba mailing list