[Samba] LDAP bind to AD fails

Stefan G. Weichinger lists at xunil.at
Wed Sep 18 16:41:21 UTC 2019

Yesterday I set up the pfsense-OpenVPN-Server to auth against the samba-AD

worked great already ...

Now without a change I get errors and wonder why.

I used the IP as "host" and TCP-STARTTLS to port 389

log.samba shows:

[2019/09/18 18:38:22.123976,  1]
  TLS ../source4/lib/tls/tls_tstream.c:1439 - A TLS fatal alert has been
[2019/09/18 18:38:22.124027,  1]
  ldapsrv_starttls_postprocess_done: accept_tls_loop:
tstream_tls_accept_recv() - 5:Input/output error =>
NT_STATUS_IO_DEVICE_ERRORstream_terminate_connection: Terminating
connection - 'ldapsrv_call_postprocess_done: call->postprocess_recv() -


unencrypted doesn't work at all ... right?

As it worked already yesterday I assume it does not have to do with some
certificate issues? AD-CA or so?

We authed with specific bind credentials etc ... and I wonder what to
look for.

Samba version 4.9.13-Debian, btw


More information about the samba mailing list