[Samba] Unable to set attributes in a samba share (error 0x00000005)

Roberto Greiner roberto.greiner at fundunesp.unesp.br
Mon Sep 9 13:11:06 UTC 2019

On 09/09/2019 04:34, Rowland penny via samba wrote:
> On 06/09/2019 17:00, Roberto Greiner via samba wrote:
>> Hi,
>> I've set a share using samba, connected it to my Active Directory, and
>> now I'm having problems when I copy files into this share.
>> To setup the AD connection I've followed
>> https://wiki.samba.org/index.php/Setting_up_Samba_as_a_Domain_Member,
>> and installed it into my Debian 9 install using APT, after
> That would get you Samba 4.5.16, this is EOL as far as Samba is
> concerned, can you upgrade to Buster ? This will get you Samba 4.9.5

Yes, I've rebuild the whole thing with Buster. I've found the actual
error. While I followed the wiki for installing everything, I was
copying the [Share] section from our current server (running samba
3.6.23, from a Centos 6). Whoever created that share was bonkers. I
remade the share using only:

        comment = Explanation of the share
        read only = no
        path = /folder

And with that it worked fine. Sorry....

>> https://wiki.samba.org/index.php/Distribution-specific_Package_Installation.
>> With the AD connection working, I've set my file share and connected to
>> it from a Windows 2008 server.
> Whoa, Windows 2000 ???? this went EOL in 2010
Nope, not 2000. 2008....Yes, I will upgrade it as soon as possible.
>   Try this smb.conf:
> [global]
>     workgroup = DOMAIN
>     security = ADS
>   .....
> Rowland

As I said, it worked when I corrected that completely insane [share]
setup. For some reason it worked in that ancient Samba 3.6, but with 4.5
and 4.9 (which I'm using now in Debian Buster), it does not work.

Tks a lot

Roberto Greiner


More information about the samba mailing list