[Samba] Cannot Find Windows Shared Printer

gw1500 i_was_yah00ed at yahoo.com
Mon Oct 14 19:40:28 UTC 2019

On 10/14/2019 1:54 PM, Giulio via samba wrote:
> On Mon, Oct 14, 2019 at 5:55 PM gw1500 via samba <samba at lists.samba.org> wrote:
>> I am running CentOS 7 with Samba version 4.9.1. I have a Windows shared
>> printer that I cannot set up but I am not sure if this is a CentOS issue
>> smbclient -L dap001 -N
>> Unable to initialize messaging context
>> Anonymous login successful
>> ?????????????? Sharename???????????? Type?????????? Comment
>> ?????????????? ---------???????????? ----?????????? -------
>> smb1cli_req_writev_submit: called for dialect[SMB2_10] server[dap001]
>> Error returning browse list: NT_STATUS_REVISION_MISMATCH
> For this specific error, see
> https://bugzilla.samba.org/show_bug.cgi?id=14151
> https://bugzilla.samba.org/show_bug.cgi?id=14152
> It appears to be an issue with smbclient; a workaround until the issue
> is solved could be
> client min protocol = SMB2
> in smb.conf.
> In any case, if you still have issues you should try using a valid
> Windows username/password; once you have it working that way you can
> then try accessing as guest/anonymous if you really need it.
Thanks. I tried the workaround but it was no help. I'm a little fuzzy on
how to add a Windows user/pwd. I THINK I'm supposed to create the file:

"/etc/samba/auth.dap001.my username"?? <== note white space in name

In that file I put:

username = "my username"
password = xxxxxxxxxx

Some documentation mentions the file "/etc/samba/smbusers" but that file
does not seem to exist with CentOS 7.

This email has been checked for viruses by Avast antivirus software.

More information about the samba mailing list