[Samba] Newby questions about using samba

Rowland penny rpenny at samba.org
Sat Nov 16 17:09:42 UTC 2019

On 16/11/2019 16:07, William Lugg via samba wrote:
> Yes, I created the unix user and a Samba user as instructed in the Wiki.
> According to the package manager, my Samba version is 4.7.6. Would you 
> say upgrading is still in order?
This is better than what I thought you would be running, but it is still 
EOL as far as Samba is concerned, but it should work ;-)
> The test I mentioned was entirely using Linux machines.  I first tried 
> using smbclient from the Linux server machine (I'm not sure if this 
> would actually work, but it seems like it should) and I also tried it 
> from another Linux machine running the same version of Samba that 
> yielded the same results.  After all that I did try the Win10 machine 
> too and found it failed as well.

Samba 4.7.6 is ntlm2 only by default, but this command (run on what you 
are calling the server) should display info about Samba:

smbclient -L localhost -N

If you do not get anything, then check if 'samba' is installed, normally 
(at least on Debian) it isn't.

If is, check if it is running: ps ax | grep 'mbd'

It should return something like this:

  3703 ?        Ss     0:00 /usr/sbin/smbd -D
  3709 ?        S      0:00 /usr/sbin/smbd -D
  3711 ?        S      0:00 /usr/sbin/smbd -D
  3765 ?        Ss     0:00 /usr/sbin/nmbd -D
15182 pts/0    S+     0:00 grep mbd

> Enabling SMB1 had no effect, the error is "The network path was not 
> found."  Based on these errors, it really doesn't sound like a failure 
> to log in, it sounds to me more like the share is simply not visible 
> to the other machines on the network, regardless of the OS they are 
> running.  I am stumped as to why this isn't working.
> FWIW, in doing some reading, I see that SMB1 is a security risk on 
> Win10, so I'm disabling it for now.  I'd like to focus on getting 
> Samba working on Linux to Linux communications first; Win10 would be 
> the icing on the cake, so to speak.
enabling SMBv1 on the Windows was a test and you are correct, you 
shouldn't use it, but without it there is no network browsing. Sharing 
will work without SMBv1, just without network browsing, but there is a 
way around this, but lets get Samba connections working first ;-)

If you still cannot get it working and Samba is running, check if a 
firewall is running and blocking the Samba ports '137, 138, 139 and 445'


More information about the samba mailing list