[Samba] List Index Out of Range

Matthew Delfino Samba List mdelfino.list.samba at KNOCKinc.com
Tue Nov 5 17:38:49 UTC 2019


I have three Samba Active Directory Domain Controllers that, from all metrics seem to be working just fine, but for one thing: When I run the following command:

# samba-tool visualize uptodateness -r

I always get the following response:

ERROR(<class 'IndexError'>): uncaught exception - list index out of range
File "/usr/lib/python3/dist-packages/samba/netcmd/__init__.py", line 185, in _run
return self.run(*args, **kwargs)
File "/usr/lib/python3/dist-packages/samba/netcmd/visualize.py", line 682, in run
utdv_edges = get_utdv_edges(local_kcc, dsas, part_dn, lp, creds)
File "/usr/lib/python3/dist-packages/samba/uptodateness.py", line 120, in get_utdv_edges
cursors = get_utdv(samdb, part_dn)
File "/usr/lib/python3/dist-packages/samba/uptodateness.py", line 86, in get_utdv
settings_dn = str(res[0]["distinguishedName"][0])

I run Ubuntu Server 16.04.6 LTS
I'm on Samba 4.10.9, which I downloaded and compiled from samba.org.

I'm just a little concerned that there's some issue lurking in my data that I would be better off to find and fix that's causing this. Plus, I would really like to see this visualization, as I find it quite helpful.

Any tips of how I could hunt down and address the cause of this?


© 2019 KNOCK, inc. All rights reserved. KNOCK, inc, is a registered trademark of KNOCK, inc. This message and any attachments contain information, which is confidential and/or privileged. If you are not the intended recipient, please refrain from any disclosure, copying, distribution or use of this information. Please be aware that such actions are prohibited. If you have received this transmission in error, kindly notify the sender by e-mail. Your cooperation is appreciated.

More information about the samba mailing list