[Samba] Use 4.10 backup in 4.9.4

Viktor Trojanovic viktor at troja.ch
Sun Mar 31 21:55:52 UTC 2019

Hi Tim,

That might well be but I wouldn't know where to even start to look. On this 
DC, the smb.conf is as simple as it gets, straight from the wiki (it 
worked, and works with 4.7). Same goes for resolv.conf, search string in 
one line, nameserver in the second (IP of itself). Using internal DNS, no 
Bind. I'd post the files but I won't be at a computer anymore today.

I moved this DC to a (Ubuntu) container now so it's relatively easy to just 
take a snapshot, do tests and revert to the snapshot if something goes 
wrong. I did this today when I tried an upgrade from 4.7.6 to 4.9.4 and ran 
the commands mentioned in the comments to the bug report which are supposed 
to mitigate the problem. But this again just created DNS issues. New ones 
though, not error 110 this time but 26.

If something is messed up in my setup, then it certainly doesn't show. As 
mentioned, with 4.7 I have no error in the log, not even relevant warnings, 
everything works smoothly. But as soon as I do the upgrade to 4.9.4, 
something breaks.

Will do my next test when 4.10 is out for Ubuntu and report back.


On March 31, 2019 23:21:41 Tim Beale <timbeale at catalyst.net.nz> wrote:

> Hi Viktor,
> In 4.10.0, the fix for https://bugzilla.samba.org/show_bug.cgi?id=13760
> will take effect when the samba process first starts. In theory, if you
> take a backup after this, that backup database should no longer have bug
> 13760 in it.
> It seems like what you're seeing might be a different problem. If
> samba_dnsupdate isn't working, then DNS may well not work. And if DNS
> isn't working, then auth probably won't either. So you might be seeing
> the same symptoms for a different reason.
> If you're using bind_dlz, then 4.10 does have bug 13841 in it.
> Otherwise, it might be worth double-checking the smb.conf and
> /etc/resolv.conf settings after the restore to make sure they're correct.
> Cheers,
> Tim
> On 31/03/19 4:44 AM, Viktor Trojanovic via samba wrote:
>> I'd like to share the results of a little experiment I did yesterday.
>> On an Arch Linux box on which in December I tried, and failed, to upgrade
>> from 4.7.4. to 4.9.4 and then had to revert back to 4.7.4, yesterday I did
>> the upgrade to the new 4.10 release. This time, everything worked, I had no
>> errors whatsoever. So, I then made a backup of the new installation, in 3
>> different ways: Online backup, offline backup, and simple file backup of
>> the whole Samba folder including smb.conf.
>> Then, I had to move the backup to a new box running Ubuntu 18.04. The
>> latest available release there, currently, is still 4.9.4. from Louis'
>> repo. I was under the assumption that now that 4.10 took care of the
>> errors, it should be possible to just use the same data in 4.9.4, all I'd
>> lose were certain functions and fixes.
>> That was clearly too optimistic. Restoring the backup on 4.9.4, in no
>> matter which way, would lead to the exact same result I used to have when I
>> tried to upgrade from 4.7.4. to 4.9.4 directly. Samba starts fine, at
>> first, but samba_dnsupdate breaks with an error 110. DNS and authentication
>> don't work. As advised in the bug report, I tried running ldbedit on
>> private/sam.ldb, I did an index rebuild, all without issues but also
>> without effect on the error.
>> Since I need this to work on Bionic, I ended up installing the default
>> package 4.7.4 and just copied (preserving all attributes) the entire samba
>> folder from the previous installation, and it works again. No error
>> messages in the log whatsoever.
>> I solved this situation for now and have no urgency to find out more about
>> it but I do wonder, did 4.10 not actually correct the data issue in such a
>> way that 4.9.4. should have been able to use it?
>> - Viktor

More information about the samba mailing list