[Samba] Use 4.10 backup in 4.9.4

Viktor Trojanovic viktor at troja.ch
Sat Mar 30 15:44:02 UTC 2019

I'd like to share the results of a little experiment I did yesterday.

On an Arch Linux box on which in December I tried, and failed, to upgrade
from 4.7.4. to 4.9.4 and then had to revert back to 4.7.4, yesterday I did
the upgrade to the new 4.10 release. This time, everything worked, I had no
errors whatsoever. So, I then made a backup of the new installation, in 3
different ways: Online backup, offline backup, and simple file backup of
the whole Samba folder including smb.conf.

Then, I had to move the backup to a new box running Ubuntu 18.04. The
latest available release there, currently, is still 4.9.4. from Louis'
repo. I was under the assumption that now that 4.10 took care of the
errors, it should be possible to just use the same data in 4.9.4, all I'd
lose were certain functions and fixes.

That was clearly too optimistic. Restoring the backup on 4.9.4, in no
matter which way, would lead to the exact same result I used to have when I
tried to upgrade from 4.7.4. to 4.9.4 directly. Samba starts fine, at
first, but samba_dnsupdate breaks with an error 110. DNS and authentication
don't work. As advised in the bug report, I tried running ldbedit on
private/sam.ldb, I did an index rebuild, all without issues but also
without effect on the error.

Since I need this to work on Bionic, I ended up installing the default
package 4.7.4 and just copied (preserving all attributes) the entire samba
folder from the previous installation, and it works again. No error
messages in the log whatsoever.

I solved this situation for now and have no urgency to find out more about
it but I do wonder, did 4.10 not actually correct the data issue in such a
way that 4.9.4. should have been able to use it?

- Viktor

More information about the samba mailing list