[Samba] Strange Excel Wine vers Issue - Sharing Violation

Neo Web neoweb at hackspherelabs.com
Wed Mar 13 18:39:03 UTC 2019

Hello Fellow Samba Users!

I have an issue that I have been trying to understand for a while, and
I have narrowed it down to different "vers=" mount types.

I have only seen this issue manifest itself on Linux clients
(Archlinux) running Microsoft Office in excel (Not that I have tried a
million others).  A year or two ago, I thought I solved it by
disabling oplocks, or at least messing with the oplock setting on an
openindiana NAS I was working with at the time.  Thinking back, I may
have just changed the vers client side like I had to do this time.  I
have been dealing with this for many years.

I have this strange issue that effects excel (Could be other MS
software too, I did not check).  I open a document, and when I go to
save it I get:  "Your changes could not be saved to "bla.xlsx' because
of a sharing violation.  Try saving to a differnet file."

I have spent some hours on trying to make this go away.  It does not
happen with windows clients.  At this time I am working with an
Archlinux client and FreeNAS server.  I am using crossover (commercial
wine) to run Office 2010.  The only way I could get the error to go
away was to set vers=1.0, and remove nounix if I have it from my mount
line.  I tried 2.1, 3.0, and 3.11.

It is a strange issue, that even happens when I disable oplocks.  I
have looked into how excel saves files, and it uses writes, renames,
and deletes.  Nothing special
I have noticed this issue gets worse and worse when I use newer Samba
vers options=.  Since I am using an Archlinux client I am always on
the latest version.

I would like to take the time to figure this out if someone could help
me by telling me what I need to do.  If someone already knows what is
going on, that works too!  Like I said, I have had this issue before,
but my most recent struggle with it started in August of last year
when I moved to FreeNAS, where I was able to use newer versions of

I have a post in the FreeNAS forum where no one has been able to help
here:  https://www.ixsystems.com/community/threads/smb-sharing-violation-linux-client-excel-2010.69421/

I think I have posted the issue in quite a few places...It is
frustrating getting help with this, because a lot of individuals
sarcastically answer stop using MS software on Linux.  While I can see
how there can be some compatibility issues with how Wine translates
paths to Office, they offer no path to actually trying to figure it

I did explore Wine paths and prefixes (configuration of the wine
enviroment, and how it maps drive letters and paths to the local file
system), but did not have any luck.

More information about the samba mailing list