[Samba] Error transferring domaindns role [SEC=UNOFFICIAL]

Thamm, Russell Russell.Thamm at dst.defence.gov.au
Thu Jun 20 06:38:27 UTC 2019


I currently have two DCs, one temporary and one permanent. Both running Samba 4.10.4 on Centos 7

I tried to transfer the roles from the temporary (julius) to the permanent (titus).

rid, schema, pdc, naming & infrastructure transferred without error.

However when I tried to transfer the domaindns role (-U administrator), I got the old

Module 'samba' has no attribute 'drs_utils'.

samba-tool fsmo show indicates that titus now owns the role but I suspect that all is not right.

When I search on this error, I see suggestions to transfer the role back. Surely I will get the same error if I try that.

I am reluctant to try transferring forestdns.

Not sure what to do!

Should I try adding import samba.drs_utils to fsmo.py as I've seen suggested, wait for the bug fix or just presume that the transfer is OK?

My domain seems to be OK - I've seen no obvious errors.



More information about the samba mailing list