[Samba] RPC Server Unavailable - Error

Andrew Bartlett abartlet at samba.org
Tue Jun 18 09:55:59 UTC 2019

On Mon, 2019-06-17 at 20:14 +0530, Anantha Raghava via samba wrote:
> Hi,
> We were running Samba-AD - Version 4.7.6 for over 2 years without any 
> errors. We have 4 Domain Controllers in our setup and DNS is BIND_DLZ 
> (BIND 9.9.4). Off late (since 8th June 2019) we upgraded the Samba-AD 
> version to 4.10.4 and all of sudden we started receiving the error "RPC 
> Server not available" when we are trying to join the new PCs to domain. 
> After multiple attempts the PC gets added to domain. We restart samba 
> server on the log on server, the error goes off. There is no specific 
> pattern for this appear to appear.

Is there anything in the Samba logs?

> We are receiving the same error whenever we are trying to add a new user 
> or modify a user attribute in RSAT. When this error comes, we have to 
> restart the RSAT server multiple times to start functioning again.

Are you restarting Samba or RSAT on the client?

> Is there is any specific reason for this error? How do we fix it.

We will need much more detail to determine that.  Does the server
operate normally when not making modifications?  What does samba-tool
dbcheck say?

If Rowand's suspicions are correct, have you tried a samba-tool dbcheck

Andrew Bartlett

Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba mailing list