[Samba] RPC Server Unavailable - Error

Anantha Raghava raghav at exzatechconsulting.com
Tue Jun 18 08:47:32 UTC 2019


We were running Samba-AD - Version 4.7.6 for over 2 years without any 
errors. We have 4 Domain Controllers in our setup and DNS is BIND_DLZ 
(BIND 9.9.4). Off late (since 8th June 2019) we upgraded the Samba-AD 
version to 4.10.4 and all of sudden we started receiving the error "RPC 
Server not available" when we are trying to join the new PCs to domain. 
After multiple attempts the PC gets added to domain. We restart samba 
service on the log on server, the error goes off. We are receiving the 
same error whenever we are trying to add a new user or modify a user 
attribute in RSAT. When this error comes, we have to restart the RSAT 
server multiple times to start functioning again. There is no specific 
pattern for this appear to appear.

Once we noticed that /etc/krb5.conf was modified and we replaced it with 
the file krb5.conf available in "/usr/local/samba/private/". That seemed 
to have solved the issue. But after about a week or so, the same error 
has resurfaced. This is somewhat strange.

Is there is any specific reason for this error? How do we fix it?

My smb.conf is as shown below.


Global parameters
         netbios name = PDC
         realm = XXXX.COM
         server role = active directory domain controller
         workgroup = XXXX
         server services = s3fs, rpc, nbt, wrepl, ldap, cldap, kdc, 
drepl, winbindd, ntp_signd, kcc, dnsupdate
         idmap_ldb:use rfc2307 = yes
         ldap server require strong auth = No
# Logs and events
         eventlog list = Security
         log level = 3
         log file = /var/log/samba/pdc.%T.log
         max log size = 1000000
         path = /usr/local/samba/var/locks/sysvol
         read only = No
         path = /usr/local/samba/var/locks/sysvol/exza.com/scripts
         read only = No

Thanks & regards,

Anantha Raghava

Do not print this e-mail unless required. Save Paper & trees.

More information about the samba mailing list