[Samba] DNS records missing for new DC joined to domain

Julien TEHERY julien.tehery at openevents.fr
Tue Jun 4 07:29:44 UTC 2019

Le 04/06/2019 à 08:57, Julien TEHERY via samba a écrit :
> Hi,
> My Setup is 3 DCs at the main site, et 14 remote DCs on 7 remote sites 
> (2 DCs per site).
> I actually joined a new DC to my domain to an existing site in which i 
> allready had a DC.
> But the fact is that i find no DNS records (such as _ldap, _kerberos, 
> _gc , etc)
> I don't know whats's going wrong with it because i joined it the same 
> way i joined the 16 other DCs..
> Is there a way to force to create those DNS records ?
> Environment:
> Ubuntu18
> Samba 4.7.6
Hi just four your information, i found the solution.
I ran a dbcheck on the first DC of the remote site inwhich i joined the 
new DC, fixed two errors and then DNS replication worked.
Before that I was able to see that when runnning host -t SRV 
_ldap._tcp.mydomain.lan, i had 17 recors on the new DC (last joined) and 
only 16 records on the other ones. That's why i ran the dbcheck, and 
everything went fine :)

More information about the samba mailing list