[Samba] Syncing sysvol -> samba-tool ntacl sysvolreset?

Jonathan Hunter jmhunter1 at gmail.com
Thu Jul 18 15:54:08 UTC 2019


On Thu, 18 Jul 2019 at 14:27, Rowland penny via samba
<samba at lists.samba.org> wrote:
> On 18/07/2019 14:11, Jonathan Hunter via samba wrote:
> > For me, at least, "ntacl sysvolreset" is definitely broken and has
> > been for the last few years. It's on my list of things I really need
> > to fix as soon as possible, but I just haven't had enough tuits -
> > probably because as Rowland says, there hasn't been much discussion of
> > any breakage and therefore I assume it works for other people. In my
> > case, it's definitely not working :)
> >
> > I'm following these bugs in bugzilla:
> > https://bugzilla.samba.org/show_bug.cgi?id=12363
> > https://bugzilla.samba.org/show_bug.cgi?id=12924
> >
> I reported this as a bug back in 2017:
> https://bugzilla.samba.org/show_bug.cgi?id=12924
> There has been only one response to it, from someone called 'Jonathan
> Hunter' ;-)

Indeed. Perhaps it really is just me, and it works perfectly for everyone else.

I found my previous attempt at digging further into the issue, I
figured that if I could get enough debugging information out of the
sysvolreset command then I could figure out exactly what was failing.
But, there are so many different layers (python, core, vfs etc.) that
I just never managed to actually insert a debugging hook that helped
(again, I ran out of tuits at the time)

The patch here looked tantalisingly perfect to help me figure out the
problem area, but it didn't work for me when I tried:

> The main problem with Sysvol on Samba is that it has NEVER used the same
> permissions that Windows does. I tried to fix this and turned up the
> problem that bug 12924 is all about. I cannot write 'C' code, so someone
> else will have to fix this.

I'm comfortable-ish with C but not familiar with the full Samba
codebase unfortunately, and my dipping in every few months hasn't
helped me either :(

My most detailed attempt at tracking down the issue was in September
2016 (wow! time really does fly..!)
but I didn't get to the bottom of it then, either.

For now I'm basically bumbling along without working GPOs :(

"If we knew what it was we were doing, it would not be called
research, would it?"
      - Albert Einstein

More information about the samba mailing list