[Samba] testparm: /var/run/ctdb/ctdb.socket missing

Neil Richardson (mail filter) g7vnqxbwx3 at liamekaens.com
Fri Jan 18 06:22:35 UTC 2019

Apologies in advance, but I have been banging my head against this
and the only Google results I've found are from 2014, and don't work
(or apply).

OS: Ubuntu 18.04 bionic
smbd: 4.9.4-Debian (the apt.van-belle.nl version)

When I run `testparm` I get:
	rlimit_max: increasing rlimit_max (8192) to minimum Windows limit
	WARNING: The "syslog" option is deprecated
	connect(/var/run/ctdb/ctdbd.socket) failed: No such file or directory
	ctdbd_connect failed: No such file or directory
	ctdbd_init_connection: ctdbd_init_connection_internal failed (No
such file or directory)
	Unable to initialize messaging context!

	$ ls -Fla /var/run/ctdb/
	total 0
	drwxrwxrwx  2 root root   40 Jan 15 21:56 ./
	drwxr-xr-x 30 root root 1100 Jan 15 21:29 ../

As you can see, I even made the directory world-writeable in case it
was a problem with ctdb/samba somehow now being able to write into
the folder.

I've seen lots of threads [1][2] where they say "Just `mkdir -p` the
directory" but those are typically referring to `/var/lib/run/ctdb`
(which I also tried creating, but it didn't help).

[1] https://ubuntuforums.org/showthread.php?t=2317968

It seems to have everything it's asking for but is still not
happy...what am I missing?

Thanks in advance,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 885 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20190117/ead9f464/signature.sig>

More information about the samba mailing list