[Samba] dns_tkey_gssnegotiate: TKEY is unacceptable

Billy Bob billysbobs at yahoo.com
Mon Jan 7 22:12:48 UTC 2019

 Call me dense, but now I am more confused. I have tried with and without quotes ... all over the place (i.e. in the smb.config and on the command line) and everything still results in errors, although not always exactly the same. Messing with the command line results in things like this:
ERROR(runtime): uncaught exception - (9711, 'WERR_DNS_ERROR_RECORD_ALREADY_EXISTS')
  File "/usr/local/samba/lib/python2.7/site-packages/samba/netcmd/__init__.py", line 177, in _run
    return self.run(*args, **kwargs)
  File "/usr/local/samba/lib/python2.7/site-packages/samba/netcmd/dns.py", line 945, in run
    raise e

I have spent aeons reading man pages, the Wiki etc., but this one is not "obvious" to me

    On Monday, January 7, 2019 3:24 PM, Rowland Penny via samba <samba at lists.samba.org> wrote:

 >  On reboot, systemctl status checks for system, samba-ad-dc and bind9
> are all without error, but still get same result for the
> samba_dnsupdate --verbose --all-names command. 

Ah, yes, if you think about it, the answer is obvious ;-)

Have you thought about it ?

And have you thought 'How about if I add '--use-samba-tool' to the command ?


More information about the samba mailing list