[Samba] Troubles upgrading jailed DC from 4.8.7 to 4.8.9

Andrea Venturoli ml at netfence.it
Mon Feb 18 11:32:34 UTC 2019

On 2/18/19 12:07 PM, L.P.H. van Belle via samba wrote:
> This sounds familiar...
> I suggest you try without the interface names and only ipnumbers.
> Test 1)
> interfaces =
> bind interfaces only = yes
> nbt client socket address =
> Try again.

Still does not work.
In addition I get:
> WARNING: The "nbt client socket address" option is deprecated

Notice I don't have in this jail, so I also tried "interfaces 
=": still no luck.

> In addition to test 1, Test 2.
>>          ntlm auth=YES
> Remove that from the smb.conf then try again.
> At least for this test remove it.

I fail to understand how this should be related to the above; in any 
case I tried and unfortunately it does not help either.
Why I have NTLM auth enabled, although I know it's "evil", is another 
story :)

> After a web search I found the solution is to add:
>   >         server services=-nbt
> Not needed really.. The default are fine.

Needed actually. It *should* not be needed, but it's the only thing that 
let Samba start presently.

> In addition to 1 and 2. Test 3,
> Block 137,138 from and to the jailed host.

You mean firewalling?
I already have ipfw running and it will not allow port 137 or 138 
from/to anywhere.

  bye & Thanks

More information about the samba mailing list