[Samba] 32 seconds vs 72 minutes -- expected performance difference?

Saurabh Nanda saurabhnanda at gmail.com
Thu Feb 14 12:04:44 UTC 2019

> Unless you upload a network capture of you mounting and doing the ls -lR
> on the client it's hard to say what really goes on. I understand you
> might not want to make it public.. but if you do

This is the last thing I'll try after I've exhausted all the other options.

How are you mounting your share (which mount options)?

Something weird is going on with the mount options. I hadn't used vers= in
my fstab earlier, and noticed the following in syslog:

    No dialect specified on mount. Default has changed to a more secure
    SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure
    dialect to access old servers which do not support SMB3 (or SMB2.1)
    vers=1.0 on mount.

Which implies that the server & client auto-negotiated a protocol version
greater than SMB2.1, right? However, to be sure, I manually specified vers=
in fstab, but something strange happened. While `man mount.cifs` claims
that the following are allowed -- 1.0, 2.0, 2.1, 3.0, 3.1.1 (or 3.11) --
few of them failed with strange errors:

# mount -t cifs -o
//[REDACTED]/uploaded_files /home/myuser/shared

mount error(11): Resource temporarily unavailable
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

# tail  /var/log/syslog

Feb 14 12:57:04 prod-backoffice kernel: [105926.746067] CIFS VFS: failed to
connect to IPC (rc=-11)
Feb 14 12:57:04 prod-backoffice kernel: [105926.767443] CIFS VFS: session
0000000044187aeb has no tcon available for a dfs referral request
Feb 14 12:57:04 prod-backoffice kernel: [105926.770039] CIFS VFS:
cifs_mount failed w/return code = -11

# mount -t cifs -o
//[REDACTED]/uploaded_files /home/myuser/shared

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

# tail  /var/log/syslog

Feb 14 12:58:54 prod-backoffice kernel: [106036.706942] CIFS VFS: Unknown
vers= option specified: 3.1

# mount -t cifs -o
//[REDACTED]/uploaded_files /home/myuser/shared

[ finally worked! ]

It seems that vers=3.0 worked, but how do I confirm that the mount ACTUALLY
happened with vers=3.0?

Further, `mount` is showing a LOT of options that I did not specify. I do
not fully understand their impact:

//[REDACTED]/uploaded_files on /home/myuser/shared type cifs

Namely: forceuid, forcegid, nouinx, serverino, & mapposix

Could any of these be causing the problems that I'm observing?

PS: vers=3.0 didn't fix the problem!

-- Saurabh.

More information about the samba mailing list