[Samba] Issues with using Samba share from Mac OS

Russell Fulton russell at fulton.nz
Sun Feb 10 20:14:03 UTC 2019

I am an old UNIX and Mac hand but new to samba.  My ultimate aim is to use a samba share with Time Machine. 
I have built an up to date version of samba (4.9.2) which has the necessary support for Time Machine and installed it on my linux system (ubuntu 18.04), and I have it sharing a volume which I can mount from my Mac. A good start ;)

The problem is that I get permission errors whenever I try and create any files or directories on the share from the Mac:

henry-crunn:timemachine rful011$ id
uid=501(rful011) gid=20(staff) …

henry-crunn:timemachine rful011$ ls -l /Volumes/
total 64
lrwxr-xr-x  1 root     wheel      1  3 Feb 10:43 Macintosh HD -> /
drwx------  1 rful011  staff  16384  3 Feb 12:04 timemachine

henry-crunn:timemachine rful011$ touch  /Volumes/timemachine/test
touch: /Volumes/timemachine/test: Permission denied

The permissions as shown by ls -l look fine but I still get permission denied on any operation that creates files on the volume.


# Mac OS support
  vfs objects = catia fruit streams_xattr
  fruit:aapl = yes

  comment = Time Machine
  path = /mnt/macmini-bb/timemachine
  browseable = yes
  writeable = yes
  create mask = 0600
  directory mask = 0700
  spotlight = no
  fruit:time machine = yes

Should the vfs object be in global or share section?   

I posted a detailed query to AskDifferent but it did not elicit any useful responses — link below.  It has more detail including screenshot showing a popup stating that a file on the share was *locked* when I tried to edit it.

It isn’t clear to me it the issue is a bug in the fruit support or simply something that I have screwed up

More information about the samba mailing list