[Samba] Hosted printer drivers can not be used

Rowland penny rpenny at samba.org
Wed Dec 18 13:45:41 UTC 2019

On 18/12/2019 13:21, Christian Haase via samba wrote:
> Hi Rowland,
>> Well yes, you may have, but at least Samba will know who your users are ;-)
>> This needs fixing before the printers can be.
> Fixed it, I have now the following and reset all file permissions:
> 	idmap config *      : backend = tdb
> 	idmap config *      : range = 3000-7999
> 	idmap config SAMDOM : backend = rid
> 	idmap config SAMDOM : range = 10000-999999
> Unfortunately I have the lines missing on my fileserver as well, that is
> a task for another year ;)
> What exactly is the issue with only "idmap config *"?  If I understand
> correctly I only have a server-local tdb but no functional problems?

Your smb.conf shows that your computer is running as a Unix domain 
member (security = ADS) and the default domain (*) is meant for the Well 
Known SIDS and anything outside the main domain. The local tdb files are 
really just caches.

You should use one of the winbind backends:

'ad' if you want the same IDs everywhere

'rid' if you only have one domain and do not want to add anything to AD

'autorid' if you have multiple trusted domains

> The printer problem shows the same behaviour as before.

Have you tried Louis's suggestion of a different driver ?


More information about the samba mailing list