[Samba] Managing samba ad dc with systemd

Igor Sousa igorvolt at gmail.com
Fri Apr 26 15:23:35 UTC 2019



I've complied samba use:
./configure --enable-debug --enable-selftest --with-systemd
make install

I haven't done anything to install MIT Kerberos and I've followed wiki to
install Samba with your default Kerberos. Then I believe that I use Heimdal

I've installed EPEL repository to install python3 and other dependencies
such as python36-dns. I can run samba with samba -D command and by systemd
with systemctl start samba-ad-dc command. I don't know how to stop samba
with samba command and when I've tried to managing it from systemd the
systemctl status samba-ad-dc and it has shown Active: failed and Status
"smbd: ready to serve connections...".


samba -b output:

[root at king ~]# samba -b
Samba version: 4.10.2
Build environment:
   BINDIR: /usr/local/samba/bin
   SBINDIR: /usr/local/samba/sbin
   CONFIGFILE: /usr/local/samba/etc/smb.conf
   NCALRPCDIR: /usr/local/samba/var/run/ncalrpc
   LOGFILEBASE: /usr/local/samba/var
   LMHOSTSFILE: /usr/local/samba/etc/lmhosts
   DATADIR: /usr/local/samba/share
   MODULESDIR: /usr/local/samba/lib
   LOCKDIR: /usr/local/samba/var/lock
   STATEDIR: /usr/local/samba/var/locks
   CACHEDIR: /usr/local/samba/var/cache
   PIDDIR: /usr/local/samba/var/run
   PRIVATE_DIR: /usr/local/samba/private
   CODEPAGEDIR: /usr/local/samba/share/codepages
   SETUPDIR: /usr/local/samba/share/setup
   WINBINDD_SOCKET_DIR: /usr/local/samba/var/run/winbindd
   NTP_SIGND_SOCKET_DIR: /usr/local/samba/var/lib/ntp_signd

Best regards,
Igor Sousa

Em sex, 26 de abr de 2019 às 11:33, Rowland Penny via samba <
samba at lists.samba.org> escreveu:

> On Fri, 26 Apr 2019 11:02:10 -0300
> Igor Sousa via samba <samba at lists.samba.org> wrote:
> > Hi Louis,
> >
> > I've modify my /etc/systemd/system/samba-ad-dc file following your
> > advice, I only changed bind9.service to named.service (I've run samba
> > on CentOS 7 with Bind9_DLZ). I've checked again if there are others
> > smbd, nmbd, winbindd an samba services on systemd, but they there
> > aren't. The samba-ad-dc service still to fail when I've tried stop
> > it. I've installed samba 4.10.2 from source on a fresh host that
> > never see any samba/smbd/nmbd/winbind packages.
> How have you compiled Samba ?
> Are you using MIT for kerberos or the Heimdal built into Samba ?
> Are you using Python3 from EPEL or somewhere else ?
> If you run 'samba -D' directly, does this work ?
> Rowland
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list